女弹药项链:金牛登山系统通达信技术指标公式—— MACD反身向上+顶底背离(未变)

来源:百度文库 编辑:好楼房产信息网 时间:2020/02/27 12:46:39

名称MACD反身向上

公式类型;其他类型(可任选)

划线方法;附图

应用软件:通达信

公式如下:(复制到公式管理器中安装即可)。

参数     最小       最大      缺省

SHORT     2        200        12

LONG      2        200        26

MID       2        200        9

DIFF:EMA(CLOSE,12) - EMA(CLOSE,26);

DEA:EMA(DIFF,9);

MACD:2*(DIFF-DEA), COLORSTICK;

 

WW:=DEA>REF(DEA,1);

DD:=CROSS(DIFF,REF(DIFF,1));

TT:WW AND DD;

DRAWICON(CROSS(DIFF,DEA),DEA,1);

低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;

STICKLINE(低位金叉,0,0.3,8,0),COLORYELLOW;

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

STICKLINE(二次金叉,0,0.2,8,0),COLORFF80FF;

DRAWICON(二次金叉,DEA*0.9,1) ;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

STICKLINE(底背离,0,0.1,8,0),COLORRED;

DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK2;

A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:=REF(CLOSE,A2+1)DIFF AND CROSS(DEA,DIFF);

DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK2;

DRAWICON(CROSS(DIFF,DEA),DEA,1);

 

 

注:

1,MACD反身向上选股:TT=1.00

2,顶背离是画绿线,底背离时划红线。

2,以上公式放牛郎已测试,可以使用,放牛郎不再解答其他问题。