唯爱 日剧:均线KDJMACD选股1

来源:百度文库 编辑:好楼房产信息网 时间:2019/08/24 09:07:34
指标说明:
本选股公式组合的条件主要有四个,1、均线多头排列;2、kdj日、周、月同时金叉或是日、周金叉,月J拐头向上;3、macd二次金叉;4、去ST和停牌的股票;
这个公式我经过一段时间的反复选股测试,效果不错,特拿出来跟大家分享!


{kdj三金叉}
MA5:=EMA(C,5);
MA10:=EMA(C,10);
MV5:=EMA(V,5);
MV10:=EMA(V,10);
K:="KDJ.K"(9,3,3);
D:="KDJ.D"(9,3,3);
V1:=MA5>REF(MA5,1) AND MA10>REF(MA10,1) AND C>REF(C,1) AND C/O>1.01;
VV1:=MV5>REF(MV5,1) AND MV10>=REF(MV10,1) AND V>REF(V,1)*1.2 ;
KD1:=K>REF(K,1) AND D>=REF(D,1);
VA:=COUNT(CROSS(K,D),4)>=1 AND COUNT(CROSS(MA5,MA10),4)>=1 AND
COUNT(CROSS(MV5,MV10),4)>=1;
{macd二次金叉}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=2*(DIF-DEA);
A1:=CROSS(DIF,DEA);
A2:=REF(A1,1);
A3:=COUNT(A2,21);{今天之前3个星期以来曾经金叉}
A4:=MA(C,5)>=MA(C,10) AND MA(C,10)>=MA(C,30) AND MA(C,30)>=MA(C,60)
AND MA(C,60)>=MA(C,120) AND MA(C,120)>=MA(C,250) ;{均线多头排列}
{去S、T、停牌}
ST:=STRFIND(stkname,'ST',1)>0;
S:=STRFIND(stkname,'S',1)>0;